Roberto Log

From Open Source Ecology
Jump to: navigation, search


HintLightbulb.png Status - Done: Finished D3D assembly To Do: D3D calibration and print test Blocks: --

Contents

Timesheet. Marcin Log. Israel Log. Ayo Log. Dixon Log. Jozef Log. Roberto Log. Abe Log. Emmanouil Log. Jose Log. Cedric Log. Michael Log. Oliver Log. Alejandro_Log. Will Log. Antonio Log. Sarah Log. Christian_Log. Ahmed Log. Josh Log.

Devs Contact Info

D3D_Meeting_Log D3D monday hangouts D3D network group D3D scrumy Wiki_Cheatsheet

D3D D3D_Part_Library D3D_Integration D3D_Development D3D_Controller D3D_Cable_Chain

Tractor_Construction_Set_2017 MicroTrac v17.10 Concept Bulldozer doc

OSE_Linux


Mon Dec 04, 2017[edit]

Chile D3D Added more pics. Today also got movement from the stepper motors by using Pronterface. I forgot to change the voltage input switch in the PSU, and it got fried with the 220V that we have here, so I'm using an ATX PSU (while I try to repair the original PSU). Here some good info about that. It seems to work fine, the only limitation is the 16A max amp capacity for the 12V rail, so I won't use the heated bed for now.

Fri Dec 01, 2017[edit]

Chile D3D

Mon Nov 27, 2017[edit]

File:LT master cad.fcstd

Sun Nov 19, 2017[edit]

File:LT master cad.fcstd File:LT track tensioner.fcstd File:LT 45.6 cu in motor.fcstd File:Bobcat QA v3.fcstd File:LT 72in Bucket.fcstd

Sat Nov 11, 2017[edit]

File:LT master cad.fcstd File:LT track tensioner.fcstd File:LT 45.6 cu in motor.fcstd

Thu Nov 09, 2017[edit]

File:LT master cad.fcstd File:LT 72in Bucket.fcstd File:Bobcat QA v3.fcstd File:LT track tensioner.fcstd File:LT quick attach.fcstd

Mon Oct 30, 2017[edit]

File:MT Bucket with QA.fcstd

Sun Oct 29, 2017[edit]

File:LT master cad.fcstd File:LT arm cylinder geometry.fcstd

Sat Oct 28, 2017[edit]

File:LT arm cylinder geometry.fcstd

Fri Oct 27, 2017[edit]

File:Loader arm.FCStd Added a fabrication drawing. more fab drawings.

Thu Oct 26, 2017[edit]

File:MT master cad.fcstd

Mon Oct 23, 2017[edit]

File:MT QA 12in stroke cylinder.fcstd File:MT 15.9 motor + hub + sprocket.fcstd File:MT tensioner.fcstd

Sun Oct 22, 2017[edit]

File:MT master cad.fcstd Enlarged QA, refined tensioner and tracks, added 2nd PC.

Sat Oct 21, 2017[edit]

File:MT master cad.fcstd Added 15.9 cu in motors and proper tensioner.

File:15.9 cu in motor.fcstd Refined shaft, easier to edit.

Fri Oct 20, 2017[edit]

File:15.9 cu in motor.fcstd Working doc.

File:Sprocket.fcstd File:0.75sprocketfor178DOM.dxf Here a way to pad a dxf:

  1. Download a dxf: right click on the download link-> Save Link As...
  2. Open the dxf in FreeCAD. It should look as a set of shapes that define the contours of the wanted piece, in 2D.
  3. Go to Draft WB, select all the shapes, go to Draft menu-> Draft to Sketch.
  4. Go to Part Design WB, select all the sketches, go to Part Design menu-> Merge sketches.
  5. Select the merged sketch and pad it. You can delete the previous shapes and sketches.

Thu Oct 19, 2017[edit]

File:MT master cad.fcstd Refined track tensioner mechanism. Still missing the bolt and nut.

Sun Oct 15, 2017[edit]

File:MT master cad.fcstd Added QA cylinders and tensioner assembly.

Sat Oct 14, 2017[edit]

File:MT-QA geometry.fcstd Used to visualize the dimensions of the cylinder that moves the quick attach plate. You have to edit the sketch to see it.

Fri Oct 13, 2017[edit]

File:MT master cad.fcstd Refined geometry for loader arms, adjusted male QA connection to arms, added 12in hydraulic cylinders to the QA. Added a shaft between arms.

Thu Oct 12, 2017[edit]

File:PC only motor + pump.fcstd

Wed Oct 11, 2017[edit]

File:MT master cad.fcstd Added quick attach and bucket. Also added some folders to better organize the parts.

Nice workflow to solve broken lines in Inkscape:

  • select all of the shapes and ungroup them, so you have no more groups
  • keep everything selected and chose "object to path" from the path menu
  • chose "edit paths by nodes" tool from the toolbox toolbar and select everything twice, first selection will show up the nodes, second will select the nodes
  • chose "join selected nodes" from the edit nodes toolbar menu
  • for objects that have a single shape this should be it, for those that have cutouts (holes), select all the shapes of the single object and use the "exclusion" tool from the path menu to create the clean single shape of it

Tue Oct 10, 2017[edit]

File:Annotation.FCMacro Macro for making annotations in FreeCAD. (It is convenient to create a button to use it)

Mon Oct 09, 2017[edit]

File:MT Bucket+teeth.fcstd Uploaded a shorter version (25", previous was 32") for the Micro Trac.

Sun Oct 08, 2017[edit]

File:Bobcat QA v3.fcstd Changed to the commercial SSQA. Missing some washers and springs. Plane plate size: 15 7/8 x 9.5 in.

Sat Oct 07, 2017[edit]

Bobcat_Standard_Quick_Attach#V3_.28Oct_07.2C_2017.29

File:Bobcat QA v3.fcstd Started according to File:Quick attach - Universal drawing.pdf

Mon Oct 02, 2017[edit]

Here another option to get nice looking isoviews. This incorporates the higher quality of SVG images. It seems to me that this workflow should replace the one used in LAI's.

  1. Prepare the scene in the FreeCAD 3D view. It means to put in the screen what you want to see, using EPA or dragging with the mouse and the Move tool, or whatever.
  2. Select all the needed parts and make compound in Part wb. It doesn't matter if the parts are together or not.
  3. Go to Draft wb, select the proper standard view (usually axonometric view - number 0 using keyboard)
  4. Select the compound object and use the tool "Creates Shape 2D views of selected objects", it is also available in the Draft menu as "Shape 2D view".
  5. Select the new Shape2DView object, click on the Placement button in property panel and mark "Apply incremental changes...". Select the z axis and change the angle to 120º, click on Apply, and OK.
  6. Select the Shape2DView object, go to File menu -> Export... and export as a Flattened SVG (*.svg).
  7. Open the SVG file in Inkscape, select the image and go to Object menu -> Fill and Stroke. Go to "Stroke style" tab and change the line width to 1,5 or the preferred value.
  8. Go to File menu -> Export PNG image. Set Export area to "Page" (the drawing should fit the canvas size), choose the filename and click on "Export".
  9. Put the PNG in Google docs or slides to add the wanted arrows and labels.


Sun Oct 01, 2017[edit]

File:MT Bucket.fcstd Dimensions here (standard dirt bucket) File:MT Bucket+teeth.fcstd

Thu Sept 28, 2017[edit]

File:Tooth Bar.fcstd (Open_Source_Tooth_Bar)

Mon Sept 25, 2017[edit]

Finished assembly workflow level 1 instructional video. https://youtu.be/9gDqRf0AU_8


Sun Sept 24, 2017[edit]

Added 3 minutes of screen captures to the assembly instructional video.

Sat Sept 23, 2017[edit]

Added 2 minutes of screen captures to the assembly instructional video.

Tue Sept 19, 2017[edit]

I've found a better way to get nice looking isoviews, here is a quick script:

  1. Prepare the scene in the FreeCAD 3D view. It means to put in the screen what you want to see, using EPA or dragging with the mouse and the Move tool, or whatever.
  2. Select all the needed parts and make compound in Part wb. It doesn't matter if the parts are together or not.
  3. Go to Draft wb, select the proper standard view (usually axonometric view - number 0 using keyboard)
  4. Select the compound object and use the tool "Creates Shape 2D views of selected objects", it is also available in the Draft menu as "Shape 2D view".
  5. Select the new Shape2DView object and Set to Top view (2).
  6. Click on the Placement button in property panel and mark "Apply incremental changes..."
  7. Select the z axis and change the angle to 120º, click on Apply, and OK.
  8. Fit the 3D view to the area you want to grab. Remember to maintain the top view (2) and to hide the objects that you don't need in the picture.
  9. Go to Tools menu -> Save picture -> Extended. Change Standard sizes to QXGA, Aspect ratio to Screen and Background to White. You can play with these options.
  10. Write the file name and save as a PNG file.
  11. Put the PNG in Google docs or slides to add the wanted arrows and labels.

See this if the Save picture tool in FreeCAD doesn't work for you.

Other task: Prepared audio track in Kdenlive for assembly instructional video.

Mon Sept 18, 2017[edit]

File:Filament Extruder Assembly.fcstd Corrected wire connections and names. Added Power cord and 2 nodes for spliced wires. Added folders to separate modules.

Sun Sept 17, 2017[edit]

Recorded audio for assembly instructional video.

Sat Sept 09, 2017[edit]

File:PC 1708 Grate.fcstd File:PC 1708 Frame top side.fcstd File:PC 1708 Frame bottom side.fcstd File:PC 1708 Frame common sides.fcstd File:PC 1708 Frame Tank inner side single hole.fcstd 2nd Revision: Script for assembly workflow Level 1 (slides 1-7).

Fri Sept 08, 2017[edit]

File:PC1708 Master.fcstd Added a grate for the Fan-Cooler assembly.

Thu Sept 07, 2017[edit]

Reviewed script for assembly workflow Level 1 (slides 1-7).

Tue Sept 05, 2017[edit]

File:PC1708 Master.fcstd Assembled according last workshop images.

Sun Sept 03, 2017[edit]

Finished script for assembly workflow Level 1 (slides 1-7) Waiting for feedback.

Fri Sept 01, 2017[edit]

Started script for assembly workflow Level 1

Tue Aug 29, 2017[edit]

Started the assembly workflow script File:PC1708 Master.fcstd Started Fan-Cooler assembly.

Mon Aug 21, 2017[edit]

File:Assembly2 workflow test.fcstd Testing the assembly2 workflow with the LFX Master CAD. Successfully assembled 85 parts.


Sun Aug 20, 2017[edit]

Quick video to show an alternative assembly workflow


Fri Aug 18, 2017[edit]

https://youtu.be/nKx5-N-p9yA Testing some Assembly2 WB features.

Script for future assembly instructional video

Fri Aug 11, 2017[edit]

File:D3D Final Assembly SVGs-PNGs.zip

D3D Final Assembly LAI

How to put color in Magnifying Bubbles

Wed Aug 09, 2017[edit]

https://youtu.be/OUIMAkR5pD4


File:Heated Bed Iso views.zip

Mon Aug 07, 2017[edit]

File:LFW tensionerswitch.fcstd Testing Emmanuoil's workflow for assembling. See Discussion.

Sat Aug 05, 2017[edit]

File:PC 1708 cooler.fcstd Design Sprint task.

https://youtu.be/f0y_xCeM1Rk Video for newbies about using Github and GitKraken.

Fri Aug 04, 2017[edit]

File:LFW Master Assembly.fcstd

Wed Aug 02, 2017[edit]

File:LFW Master Assembly.fcstd

Tue Aug 01, 2017[edit]

https://youtu.be/3l_AytmBKl8

Mon Jul 31, 2017[edit]

File:LFW puller.fcstd Added labels with the Master-Index numbers. There's a little vertical misalignment between the Puller Brackets and the Motor Bracket. I also replaced the M3x8mm SHCS by M3x0.5in SHCS (Gear Motor), because the first one was too short.

Sun Jul 30, 2017[edit]

I think I've discovered how to get the right DXF files for cutting. First I took these DXF files as an example: File:Trencherdxfs.zip. So, what we need is a 2D drawing for the face to be cut, with DXF format.

These are the steps:

  1. Follow Abe's procedure: DXF_Export_in_FreeCAD (I'd add that to see the DXF options, I had to go to Draft Workbench before). But do not export yet.
  2. Open the FreeCAD file to export.
  3. Go to Draft Workbench.
  4. Select the object to export.
  5. Select a standard view (keys 1-6), which shows the face to be cut.
  6. Go to Draft menu-> Shape 2D view.
  7. Select the new object Shape2DView and check it's ok.
  8. Export as Autodesk DXF(*.dxf).
  9. Open the DXF file in LibreCAD and check it's ok.

File:CEB Press Drawer Side.dxf This is what I got.

Sat Jul 29, 2017[edit]

File:LFW 6x15.875mm Screw.fcstd

File:LFW SA 5.fcstd

Fri Jul 28, 2017[edit]

File:CEB Press Drawer Side.dxf

Sun Jul 23, 2017[edit]

Updated some links at the Lyman_Filament_Extruder#Master_Index and Working Doc. I think we are missing the switches in the LFX Master Index. (2 Hours)

Sat Jul 22, 2017[edit]

File:CEB Press Drawer Side.fcstd

Fri Jul 21, 2017[edit]

File:Filament Extruder Assembly.fcstd Corrected Fan placement, added Wires, Welding Blanket, Color Code and SSR screws. Still missing PSU screws, I'm not sure where to put them. I think wire connections, colors and names should be revised. (6 Hours)


Thu Jul 20, 2017[edit]

File:Filament Extruder Assembly.fcstd Added the Fan plus all the washers, nuts and bolts. Only missing wires, screws for Electronics, and the Welding Blanket. Also updated many files and pictures at the part library.(4 Hours)

Mon Jul 17, 2017[edit]

Today I tried to explain what I understand about File Simplification, because I see it is not clear enough. Link

Sat Jul 15, 2017[edit]

As I was all the day without internet, I worked offline on the File:Filament Extruder Assembly.fcstd. There were many things to fix and better detailed parts to add. Still are missing some washers, bolts and nuts for the Flange and motor and the detailed SSR.

Fri Jul 14, 2017[edit]

Today I followed the process on slide 3 in the working doc. Finished Fasteners and small parts visual diagram for the Big Box Enclosure module, including purchasing links, CAD Files and updated the Part Library and Master Index. Began a visual diagram for the Extruder-Auger-Flange module (slides 9-10) and coordinated with Dixon about what's next. I also asked Alejandro Calegtriminio_log to do a simplified CAD for File:46 Part 20b case.stl.

Thu Jul 13, 2017[edit]

I will focus on the visual diagram and CAD files for the non electronic parts in the Box and Extruder Module.

Tue Jul 11, 2017[edit]

File:Wiring test.fcstd

Mon Jul 10, 2017[edit]

Lyman_Filament_Extruder_Part_Library#Assembled_Modules_Gallery

Sun Jul 09, 2017[edit]

File:Filament Extruder Assembly.fcstd

Sat Jul 08, 2017[edit]

Filament Extruder Assembly. Includes Bix Box Enclosure + Hopper + Extruder Barrel + Auger + Flange + Thermal Components.

Thu Jul 06, 2017[edit]

File:47 Part 21 coupler.fcstd

Mon Jul 03, 2017[edit]

Working Doc.

File:Big Box Enclosure + Hopper.fcstd Final assembly with merged files.

The following files are duplicated and should be deleted:

  1. File:Case TL.fcstd
  2. File:Knob.fcstd
  3. File:Case BL.fcstd
  4. File:Corner Panel TR.fcstd
  5. File:Corner Panel TL.fcstd
  6. File:Corner Panel BL.fcstd
  7. File:Fan Bracket.fcstd
  8. File:Front Panel.fcstd
  9. File:Bottom Panel BL.fcstd
  10. File:Bottom Panel BR.fcstd
  11. File:Bottom Panel TL.fcstd
  12. File:Bottom Panel TR.fcstd
  13. File:Corner Panel + Hole.fcstd
  14. File:Side Panel R.fcstd
  15. File:Side Panel T.fcstd
  16. File:Side Panel L.fcstd
  17. File:Case BR.fcstd
  18. File:Case TR.fcstd
  19. File:Extruder Case.fcstd
  20. File:H Hopper.fcstd

Fri Jun 30, 2017[edit]

File:26 Extruder Case.fcstd

File:57 Part 41 box.fcstd

Thu Jun 23, 2017[edit]

https://youtu.be/RiIm_v49B3c

FreeCAD Source File.

Kdenlive Source File.

Tue Jun 20, 2017[edit]

https://youtu.be/MWJ7SA2j4sg

Script

Sat May 27, 2017[edit]

https://youtu.be/Hk8F3STZfEM

File:Heated bed 01.fcstd FreeCAD source file.

Short_Idler_LAI Sample of finished LAI.

Script for getting an iso view:

  1. Install this Macro. How to install macros in FreeCAD.
  2. Open a FreeCAD file with the part you want to extract the isometric view from.(If the wanted part is separated in several smaller parts, go to Part Workbench, select all of those parts and use the tool "Make compound" in the top dropdown menu. In this video I used EPA Workbench for assembling the Universal Idler piece with 2 nuts, then I went to Part Workbench for making compound).
  3. Select the wanted part, by double clicking over it.
  4. Execute the Macro (Can take between 0 and 1.5 minutes)
  5. Double click in the new drawing page called "AutoDrawing".
  6. You can change position and scale for each drawing in the combo view data tab (after selecting the wanted drawing). Recommended scale between 2,00 - 6,00. The smaller the piece, the larger the scale.
  7. Use the tool: "Export a page to a SVG file"(in Drawing Workbench).
  8. Open the SVG file with Inkscape.
  9. Make required fixes to the image using tool: "Edit paths by nodes(F2)".
  10. Export PNG image.

Script for making a LAI document:

  1. Go to Instructionals_Cover_Page click in edit.
  2. Go to File - Make a copy.
  3. Enter the name of the LAI you're working on. Click OK
  4. Share the file with the world.
  5. Fill the template.
  6. Add a new slide. Choose preferred layout.
  7. Insert the PNG image you just exported from Inkscape.
  8. Repeat until you have all the necessary images.
  9. Once you have finished with images, compress(zip) SVG files(those retouched with Inkscape) and upload the zip file to the wiki.
  10. Add a new slide to your LAI document and include links to: Working script (I used D3D_Scripts), FreeCAD Isometric source file, and Inkscape source file (the zip file you just uploaded).
  11. Create a new wiki page with the name of your part.
  12. In your LAI document go to: File - Publlish to the web - Embed. And copy the embedding link.(The link starts with: <iframe...)
  13. In your LAI wiki page go to Edit and insert the embedding link this way: <html>"your link (without quotes)"</html>.
  14. Put a link for editing your LAI document. In the LAI document click in: Share - 'Get shareable link' or 'Copy link'. Put the link in your LAI wiki page this way: ["your link (without quotes)"# Edit].
  15. Share your LAI wiki page in the OSE network group.


File:Iso view.FCMacro Now selected object is copied into a new document and its placement is reseted before the iso views are obtained. This way, the original FreeCAD file doesn't change and the object original placement doesn't affect the iso views placement.

Mon May 22, 2017[edit]

Short Idler LAI.

Sun May 21, 2017[edit]

File:Iso view.FCMacro Macro for getting isometric views in FreeCAD (created from https://www.freecadweb.org/wiki/Macro_Automatic_drawing)

Fri May 19, 2017[edit]

I tested Laszlo technique to extract B&W views from FreeCAD files. Put my results in section 4. in this Google Drawings file.

Tue May 16, 2017[edit]

FreeCAD source file

Mon May 15, 2017[edit]

Axis Idler LAI in Google drawings

My first attempt of LAI for the Short Idler. See comments

Sun May 14, 2017[edit]

Short Idler LAI

Fri May 12, 2017[edit]

File:Heated bed isometric view 01.fcstd

Thu May 11, 2017[edit]

My FreeCAD Isometric View workflow

File:Axis Idler Side isometric view 01.fcstd Finally got my first isometric view using Drawing_dimensioning Workbench in FreeCAD.

Fri Apr 28, 2017[edit]

File:D3D Heated bed 01.kdenlive Kdenlive Source file.

File:D3D Heatbed support 01.kdenlive Kdenlive Source file.

File:Heated bed 06.fcstd Finished exploded assembly of Heated bed.

Thu Apr 27, 2017[edit]

File:Heated bed 05.fcstd Finished assembly of Heated bed.

File:Heated bed 03.fcstd Starting with the PEI and thermistor.

Wed Apr 26, 2017[edit]

File:Heated bed 02.fcstd Working on Heated Bed wiring.

Mon Apr 24, 2017[edit]

File:Heated bed 01.fcstd FreeCAD Source file.

Sun Apr 16, 2017[edit]

Another version for the Animated Assembly of D3D Idler-Side.

File:Idler side 03.fcstd FreeCAD Source file.

File:D3D Short Idler Side 03.kdenlive Kdenlive Source file.

Sat Apr 15, 2017[edit]

Finished video: Animated Assembly of D3D Idler-Side

File:Idler side 03.fcstd Animated Assembly of D3D Idler-Side with the flanged bearing.

Fri Apr 14, 2017[edit]

Animated D3D Idler-Side. File:Idler side 03.fcstd

Thu Apr 13, 2017[edit]

D3D Axis Idler Side with M6x18 bolts, File:Idler side 02.fcstd

D3D Axis Idler Side

Figuring out how to create the M6x18-Screw File:M6x18.fcstd

M6x18-Screw

Wed Apr 12, 2017[edit]

I followed the D3D Assembly Animation Script for the Axis Idler Side and this is the result: File:Idler side 01.fcstd

Thu Mar 30, 2017[edit]

File:MyFirstCube.fcstd