CEB Press/Manufacturing Instructions/Code Upload

From Open Source Ecology
Jump to: navigation, search

Contents

[edit] Tools

  • Computer
  • USB Cable
  • CEB Press Electronics

[edit] Software

  • Arduino Integrated Development Environment

http://www.arduino.cc/en/Main/software

  • On Ubuntu 12.04, open terminal with ctrl + alt + T then cd FOLDERNAME until you reach the folder that contains the "arduino" file, then sudo ./arduino to open the arduino IDE as a super user (you need to be a super user else the Tools>Serial Port will be greyed out).

[edit] Compatibilizing Arduino IDE for Ubuntu 10.04 LTS

To run Arduino IDE successfully, you need to make sure that certain software is installed on your computer. For newer versions of Ubuntu, there are guides within the Arduino website.

  • The following steps are a summary of the information in this webpage:

http://www.pluggy.me.uk/arduino-ubuntu/

  • Open System>Administration>Synaptic Package Manager, then type your password
  • In Synaptic Package Manager, search for jre, then mark for installation the item with the following name:

Openjdk-6-jre

  • Note: marking these items will bring up other packages also to be marked. Click "mark" during these times.
  • In Synaptic Package Manager, search for gcc-avr, then mark for installation the item with the following name:

gcc-avr

  • In Synaptic Package Manager, search for avr-libc, then mark for installation the item with the following name:

avr-libc

  • In Synaptic Package Manager, click "Apply"
  • Restart your computer

[edit] Upload Steps

  • Using the computer, open the Arduino Integrated Development Environment
  • Within the Arduino IDE, click File > Open (a search box should pop up)
  • Within the Arduino IDE Search Box, navigate to and click on the .ino file in which the desired code exists, then click Open
  • Within the Arduino IDE, click Compile (if compiling failed, fix the code)
  • Connect the computer to the Arduino microcontroller via the USB cable
  • Within the Arduino IDE, click Tools > Board and select the Arduino board that you are using (ex. Arduin Uno)
  • Within the Arduino IDE, click Tools > Serial Port and select the serial port
  • Within the Arduino IDE, click Upload and wait for upload completion
  • Disconnect the USB cable from the Arduino microcontroller OR if you want to see messages from the Arduino board, click Tools > Serial Monitor and do not disconnect the USB cable.

[edit] Contact a Human

Yoonseo Kang - [email protected]

Personal tools
Namespaces

Variants
Actions
Navigation
Open Source Ecology
Toolbox
Topics