Ubuntu Mac USB
Contents
[hide]Running Ubuntu Using USB Flash Drive
Ubuntu's Instructions
https://help.ubuntu.com/community/How%20to%20install%20Ubuntu%20on%20MacBook%20using%20USB%20Stick
Get the .ISO
Ubuntu 12.04 LTS 32 bit
http://www.ubuntu.com/download/desktop
Convert the .ISO
Convert the .iso file to .dmg using the convert option of hdiutil
In Terminal, type (OS X tends to put the .dmg ending on the output file automatically):
sudo hdiutil convert -format UDRW -o ~/path/to/target ~/path/to/ubuntu.iso
General example:
YOURNAME-MacBook-Pro:~ USERNAME$ sudo hdiutil convert -format UDRW -o ~/IMAGENAME ~/UBUNTUVERSIONNAME.iso
Specific example:
Graham-Robertsons-MacBook-Pro:~ graham$ sudo hdiutil convert -format UDRW -o ~/graham.dmg ~/ubuntu-10.04.2-desktop-i386.iso
Insert then Unmount USB Flash Drive
Put your USB Flash Drive into the USB port of your Mac (usually at the sides of the mac)(flip the USB flash drive if not fitting)
List the disks connected to your devices. Determine the device node assigned to your flash media (e.g. /dev/disk2)
diskutil list
Unmount your USB flash drive disk by inputting this code:
diskutil unmountDisk /dev/diskN
(replace N with the disk number from the last command; in the previous example, N would be 2)
Process and Transfer Ubuntu disk image onto USB flash drive
Specific example:
sudo dd if=/Users/graham/graham.dmg of=/dev/disk2 bs=1m
This step requires patience, as it takes a long time. Wait for Terminal to respond.
Eject USB Flash Drive
Type:
diskutil eject /dev/diskN
Replace "N" with your disk number.
Remove USB Flash Drive
Restart your Mac
Hold alt/option key while rebooting.